Jump to content
Sign in to follow this  
OzShrimp

Using no planaria advice

Recommended Posts

OzShrimp

Well i am using my No planaria for the first time, am i better half dosing or just full dose?

I am guessing 4 scoops for standard 4 ftr since it is about 208 litres and 1 spoonful per 50 litres. Just want any advice to avoid loss of shrimp aswell

Share this post


Link to post
Share on other sites
Dean

My advice is don't bother using "no planaria" you have 50/50

Chance of killing shrimp. It's a real hit and miss product.

Stick with internal paracite product from aquotix. Can't go wrong

Share this post


Link to post
Share on other sites
OzShrimp

hmmmm well i jsut did one scoop already lol. My internal parasite clear wont come until end of next week tho so whats likelyhood of losing my shrimp ?

Share this post


Link to post
Share on other sites
Dean

I would just wait mate, not worth the risk. 1 more week is worth the wait

Share this post


Link to post
Share on other sites
OzShrimp

gonna do water change to try get most of it out of tank now :(

PLanaria dont kill adult shrimp do they ? mainly just shrimplets ?

Share this post


Link to post
Share on other sites
OzShrimp

shits going down hill lol, just took out lots of water and realised got no seachem stability to add to new water ARRRRGh wanna scream

Share this post


Link to post
Share on other sites
OzShrimp

well fingers crossed i have no more dramas until i get internal parasite clear, have added carbon to canister filter and did a substantial w/c

Share this post


Link to post
Share on other sites
MrShrimp

"no planaria" is over rated I'm my opinion. It's a gamble using that product, I 've lost crystals and cherries using no planaria. Didnt kill alot of shrimps but still they were personal collection.

Share this post


Link to post
Share on other sites
ineke

Oh Oz you are in the wars aren't you:( hope it all goes OK for you:encouragement:

Share this post


Link to post
Share on other sites
OzShrimp

well i did a 25% water c hange with rain water, added carbon to the filter (and my lounge room floor) so fingers crossed. Just adds to my woes at the moment things arent going so great with my tank lol

Share this post


Link to post
Share on other sites
Heavyd

I have used No Planaria with no issues, but as others have said it seems to be hit and miss. I didn't see any shrimp deaths from my planaria, when I had them. So waiting until the end of the week shouldnt be an issue, and it's better to lose a couple of shrimp than having mass deaths from the No Planaria. Incidentally my tank that I treated is the same volume as yours, and I did a full dose, half dose and then another full dose because there were still planaria cruising about. I didn't lose any shrimp from doing this.

Share this post


Link to post
Share on other sites
zuuutoootuuu

If you are dead set on using no planaria then google your batch number to see if anyone has had a problem with it.

Share this post


Link to post
Share on other sites
Squiggle
added carbon to the filter (and my lounge room floor)

Does this mean you've increased your carbon footprint, the greenies won't be happy to hear about this, hahaha :smiley_simmons:

Share this post


Link to post
Share on other sites
ninja

Squiggle, don't swear on this forum please???????

Share this post


Link to post
Share on other sites
OzShrimp
Does this mean you've increased your carbon footprint' date=' the greenies won't be happy to hear about this, hahaha :smiley_simmons:[/quote']

hand print to lol

Share this post


Link to post
Share on other sites
Kitz

I've used no planaria about 2-3 years ago I would never use it again as there is a chance of killing shrimp.

i slowly killed my shrimp, when I say slowly that means the population was dropping and babies disappearing.

Share this post


Link to post
Share on other sites
OzShrimp

Well definately no more dosing of it for me :) hopefully the carbon will do a good job, only negative i have seen from that 1 scoop is my golden has lost its color

Share this post


Link to post
Share on other sites
CNgo2006

Just put in my first dose of Internal Parasite Clear and few hours in I have noticed some shriveled up hydra already...will let you guys know how it pans out but looks good so far, shrimp are active as ever that includes shrimplets as well.

Share this post


Link to post
Share on other sites
OzShrimp

please do! look forward to your outcome :) the more reviews the better. I wonder if they will end up advertising it targetting planaria and hydra aswell.

Share this post


Link to post
Share on other sites
samwise

have you thought of building a trap for the planaria instead of chemically treating them... pretty much drill a hole in the bottom of a water bottle, put a bit of meat in the water bottle and the planaria climb into the bottle at the bottom, but try to exit out the top with the light and hence get trapped.. rinse and repeat till you have no planaria... im sure google has much better explanations than mine :-)

I have found in the past that even when i didn't kill my shrimp with no planaria the females went off getting berried for 2 months after.

Sam

Share this post


Link to post
Share on other sites
CNgo2006

Update on Internal Parasite Clear...This product is great! It is more effective on hydra I found all hydra disappeared after first dose, for planaria after the first dose little baby planaria remained I guess these were the ones hiding in substrate...after 2nd dose I still noticed 1-2 tiny ones so dosed again and not a single one in sight for 2 days now! In conclusion killed all hydra and planaria when used correctly and did not harm any shrimp what so ever. One thing to note though is that it also wiped out my snails so another use for it!

Share this post


Link to post
Share on other sites
newbreed

I don't understand how this can kill planarian, hydra and snails yet have no supposed affect on the shrimp. Can we please get an update on this, have you lost any shrimp from this tank in last month? Cheers jc

Share this post


Link to post
Share on other sites
torface

Not sure how it works, sorry, but Dean did a thorough test on the Internal Parasite Clear with no deaths. He even tried it on his TB tank!

I had no deaths when I used it too, but I only used it on a cherry tank.

Share this post


Link to post
Share on other sites
newbreed

Cool thanks for the feedback. If a few have tested with good results then I am sold too. Many thanks.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



  • Must Read SKF Articles

  • Register today, ask questions and share your shrimp and fish tank experiences with us!

    Join Our Community!

  • Posts

    • Myola
      So here's the thing. I've got 6 bare-bottom neo tanks that have been chugging along just fine for quite a while now. There are lots of babies and it's extremely rare to have any deaths, even when I add new shrimp.  I use remineralised rain water that has been filtered through an RO. I stopped using substrates in the tanks after I had ongoing issues with it breaking down, and to be honest, I wouldn't go back. Now I want to start some caridina tanks for tangerine tigers, CRS and blue bolts but want to know if I can get away with bare bottoms in them too. My RO filtered rain water comes out at pH 5, and when I add Salty Shrimp 'Bee shrimp' minerals to give me a GH of 5, the pH goes up to around 5.8. Do I really need the buffering affects of a substrate if my water is already within an acceptable range for caridinas? 
    • jayc
      It must have been an aluminium heatsink. The Indium in Liquid metal will eat through aluminium. Only copper or nickel plated heatsinks can be used with liquid metal. It says so on the packet, at least my pack of Thermal Grizzly Conductonaut does.
    • jayc
    • kms
      I will try to add all the old tank's shrimps at the end of August to the new tank, had a problem with my chiller this morning, try to make it more efficient by adding a better heat sink grease, I added a liquid metal grease, apparently you can't add liquid metal, when heating up, the heat sink turning to dust, along with part of the cooler inlet and outlet. So far the shrimps are ok.    
    • sdlTBfanUK
      I have had the new shrimps a week and have ordered some new ones(10) for delivery friday. There are probably at least 6 of the 8 alive (they may even all be alive still) but as the tank is so densely planted it is difficult to tell, but I saw 2 black and 2 red this morning, as yesterday, but I'm sure 1 red and  1 black weren't the same as the ones I saw yesterday so there are probably at least 6, if that makes any sense??? Anyway that will be it for now and I will just let the tank and shrimps do there thing once this batch are in there in a couple of days, and I can get back to the usual routine as was, before this unfortunate event wiped out the last lot. All parameters are good, including the nitrates now, but there are a lot of brown patches on the plants and moss balls still......... It all looks a bit drab and uninspiring and brown!!! I probably just need to be a bit more patient? I will do some maintenance tomorrow and a small 2L water change, then the new shrimps will go in on friday after acclimatising. The shrimps were totally uninterested in the spinach or shrimp lolly I put in at the weekend but I am assuming they have so much biofilm at this stage that that is keeping them busy and well fed and they are staying under cover until they get used to their new environment and this strange ugly monster that keeps peering in at them through the glass from time to time? I guess if some 100ft tall bloke kept peering through my window a few times a day I would be a bit nervous/reserved shall we say? I removed the spinach and the shrimp lolly and put the shrimp lolly in the betta tank and within minutes there were 10 shrimp on it so there was definitely nothing wrong with that shrimp lolly! Simon
×