Jump to content
  • Must Read SKF Articles

  • Join Our Community!

    Register today, ask questions and share your shrimp and fish tank experiences with us!

  • Posts

    • Steensj2004
      Another mother-bleeping dead adult. I have no idea what’s going on. You’d think all these micro sized babies would be dying too.... I don’t get it.
    • sdlTBfanUK
      This really isn't going well this time. I am not really sure why either? The plants are nowhere as green and lush as the other tanks and the shrimps seem to be dying off slowly despite all parameters being perfect! The different substrate must be part of this but as it is shrimpking I can't believe it can be the main problem! After a lot of considering the only thing I can come up with is I tend to do this tank the same day as I do washing so I 'MAY' be contaminating the water if I have some washing product residue on my hands but this is really clutching at straws - it is the only thing I can come up with and a possibility............... I have left a note next to the tank to remind me for the future! I am thinking of changing 50% of the water and 1 of the 2 sponges at the weekend and running the tank for a few weeks then trying One last time a new batch of taiwan bee shrimps, and at least they will be in situ by the end of our winter so they should readily breed this lot? I probably have just under 10 shrimps left. Any advice appreciated on what they would do? I have a few days to mull it all over? Simon  
    • Steensj2004
      Two weeks ago on the fert.   no, it’s only on the upper side along the back, and some along the sides. I want to upload  better pictures but this is confusing. It won’t let me.... the threshold for file size is never the same...
    • sdlTBfanUK
      When did you last use the ferts? If you are doing that once a month and that was within the last week it may be that? It could be the eggs in the saddle if the shell is a bit transparent, does it just appear in that area? Simon
    • Steensj2004
      I will try, this phone doesn’t do great pictures.   I started using on squirt a month, just for the iron. The red plead plants were suffering. Heater is operating normally, and I don’t THINK I did anything to the tank to cause introduction of something to kill them. I suppose I’m being too picky as it was clearly two of the older,  originally purchased adult shrimp.    The marking wasn’t originally there. It seems to be on females, and only when they are berried. It then never goes away.
×
×
  • Create New...